sincerit 2669 Romantic 扩展欧几里得

2669 Romantic
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10370 Accepted Submission(s): 4427

Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
…Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy Xa + Yb = 1. If no such answer print “sorry” instead.

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put “sorry” instead.
Sample Input
77 51
10 44
34 79
Sample Output
2 -3
sorry
7 -3

ax + by = gcd(a,b)
当gcd(a,b) == 1时 x即为答案
当gcd(a,b) != 1时该题不考虑不为1的情况这个是扩展, 先当成1计算最后结果x,y同乘与gcd(a,b)
gcd(a,b)当成1的时候,因为a, b这两个系数不变,那就相当于从x,y这两个结果约去了gcd(a,b),最后要乘回去
当要求x大于0时, while (x <=0 ) x += b, y -= a;

#include <iostream>
using namespace std;
typedef long long ll;
// ax + by = 1;
ll extgcd(ll a, ll b, ll &x, ll &y) {
  ll temp;
  if (b == 0) {
    x = 1;
    y = 0;
    return a;
  } else {
    temp = extgcd(b, a%b, y, x);
    y -= (a/b) * x;
  }
  return temp;
}
int main() {
  ll n, m;
  while (cin >> n >> m) {
    ll x, y;
    ll k = extgcd(n, m, x, y);
    if (k != 1) cout << "sorry\n";
    else {
      // a(x+b) + b(y-a) == ab + ax + by - ab = 1
      while (x <= 0) {
        x += m;
        y -= n;
      }
      cout << x << " " << y << "\n";
    }
  }
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值