sincerit 483 Nightmare(无标记的BFS)

483 Nightmare
时间限制:1000 ms | 内存限制:65535 KB
难度:4
描述
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

  1. We can assume the labyrinth is a 2 array.
  2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
  3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
  4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
  5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
  6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
    输入
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
    There are five integers which indicate the different type of area in the labyrinth:
    0: The area is a wall, Ignatius should not walk on it.
    1: The area contains nothing, Ignatius can walk on it.
    2: Ignatius’ start position, Ignatius starts his escape from this position.
    3: The exit of the labyrinth, Ignatius’ target position.
    4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

输出
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

样例输入
2
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
样例输出
4
-1

大佬的想法: http://blog.sina.com.cn/s/blog_91e2390c01014cwc.html
虽然同样是BFS但是这里不同的是:对于走过的路径不能标记,因为可能还要走,注意题目要求:如果可以,可以走任意多遍。
这就引发了一个问题,如果不缩减搜索范围,怎么可能走得出来呢?应该说这题好就好在不是根据走过的路径来标记,而是根据前后两次踏
上同一位置是bomb离explode的时间长短来标记。简言之,如果第二次踏上一个位置,那么找出路已用的时间肯定是增加了,那为啥还要走上这条
路呢?唯一的追求就是bomb离爆炸的时间增大了。所以可以利用这个条件来标记了。每次在入队前检查下爆炸时间是否比上次在同一位置的大,若是,则入队;反之,入队无意义了。

而我的代码是根据剩余时间来缩短搜索范围的,因为这里路径是没有标记的,每次搜索的可能会经过已经走过的点,而每次经过时有变化的就是剩余的时间不同,可以根据剩余时间来缩短搜索范围,即如果第二次走回这个点,爆炸时间比第一次的要大,那么这是有效的走法可以踏入第二次,如果更小那么说明往回再经过一次是无用工,只会浪费时间
我还从重置时间那里缩短搜索范围,当到达重置点就把该点标记成无法通过,防止再往回搜索而使队列无法为空

#include <stdio.h>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
#define N 10
using namespace std;
int dx[4] = {0, 1, 0, -1};
int dy[4] = {1, 0, -1, 0};
int n, m, bx, by, ex, ey;
int map[N][N];
struct node {
  int x, y;
  int use;
  int remain;
};
void BFS(int x, int y) {
  node s, nt;
  s.x = x; s.y = y;
  s.use = 0;
  s.remain = 6;
  queue<node> que;
  que.push(s);
  while (que.size()) {
    node t = que.front();
    que.pop();
    if (map[t.x][t.y] == 3 && t.remain > 0) {
      printf("%d\n", t.use);
      return;
    }
    for (int i = 0; i < 4; i++) {
      nt.x = t.x + dx[i];
      nt.y = t.y + dy[i];
      nt.use = t.use + 1;
      nt.remain = t.remain - 1; 
      if (nt.x < 0 || nt.x >= n || nt.y < 0 || nt.y >= m || map[nt.x][nt.y] == 0)
        continue;
      if (nt.remain <= 0) // 根据每次剩余的时间来缩短搜索范围 
        continue;
      if (map[nt.x][nt.y] == 4) {
        nt.remain = 6;
        map[nt.x][nt.y] = '0'; // 并且每次到这里的时候修改成0,就无法往回搜索也可以减少搜索范围,不然就会陷入死循环队列无法为空 
      }
      que.push(nt);  
    }
  }
  printf("-1\n");
}
int main() {
  int t;
  scanf("%d", &t);
  while (t--) {
    scanf("%d%d", &n, &m);
    for (int i = 0; i < n; i++) {
      for (int j = 0; j < m; j++) {
        scanf("%d", &map[i][j]);
        if (map[i][j] == 2) {
          bx = i; by = j;
        } else if (map[i][j] == 3) {
          ex = i; ey = j;
        }
      }
    }
    BFS(bx, by);
  }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值