我的地盘

CALL ME SING,STEVEN SING!!

旧版本Xcode工程在Xcode4.5下真机无法调试问题的解决

iOS6发布不久后,Xcode4.5也发布了。于是第一时间下载安装,并将之前安装的XCode删除了。后来一直用着没事,近来有个旧项目要修改有些bug,增加对iOS6和iPhone5的支持。做完该做的一切后,打算在真机上测试一下,编译成功但却无法运行。之前在模拟器上调试是一直没出现问题的。弹出的提示如下:


按往常的办法,搜索了一遍,按有些文章说的,将Deployment Target改成最低支持的4.3,之前是3.0的。修改后问题依然。

后来又尝试了好几个方法,还是不能解决。

搞了半天结果还是没有搞定,后来想想,会不会是Architectures支持的问题。项目是支持3.0以上的设备的,所以Architectures是armv6 armv7。尝试将armv6删除,换回默认值,编译运行,这下还真行。shit,搞了半天的东西,原来是这个设置问题。设置如下:


偶尔又发现了一个在Xcode下支持armv6的办法,地址如下:

http://blog.csdn.net/seamanjiang/article/details/8074456

阅读更多
个人分类: iOS开发
想对作者说点什么? 我来说一句

真机调试包iOS11.1

2018年03月30日 5.88MB 下载

DeviceSupport 支持iOS11.2.rar

2017年11月24日 32.33MB 下载

DeviceSupport 支持iOS11.2

2017年11月23日 32.33MB 下载

没有更多推荐了,返回首页

不良信息举报

旧版本Xcode工程在Xcode4.5下真机无法调试问题的解决

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭