鱼翔浅底:进阶二N题

Description

A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race. 

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it? 
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.

Input

The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.

Output

For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.

Sample Input 

2 12.5
  5 0:23:21 0:25:01
 42 0:23:32 -:--:--
  7 0:33:20 0:41:35

Sample Output

  5: 3:52 min/km
 42: -
  7: 6:00 min/km
水题,淹死——注意点:这里读入的时候要注意把回车先吃了,然后读入可以用%s再逐步抽出时间,或者用%1c一个一个读,网上有的人写的用%c即可,但是我是崩了,建议还是加个1,一个一个读容易处理0;然后就是四舍五入,就是在算出的还没换成m:ss格式的时间后面+0.5即可,时间声明为int;-:--:--这里记得识别之后还要把这个都入完;输入编号时有人用%3d,但是我是直接用空格把前面的都吃了;输出编号记得%3d。
代码:
#include<cstdio>
#include<cstring>

int main()
{
	char h, min[2], sec[2];
	int i, j, n,num,sum,flag,time;
	float dstan;
	scanf("%d%f", &n, &dstan);
	while (scanf("%d ", &num)!= EOF)
	{
		flag = 0;
		for (i = 0,sum=0;i < n;i++)
		{
			scanf(" %1c:%1c%1c:%1c%1c", &h, &min[0],&min[1], &sec[0],&sec[1]);
			if (h == '-')
				flag = 1;
			sum = sum + (h - '0') * 3600 + ((min[0] - '0')*10+min[1]-'0') * 60 + (sec[0] - '0')*10+sec[1]-'0';
		}
		time =	sum / dstan+0.5;
		printf("%3d: ",num);
		if (flag == 1)
			printf("-\n");
		else
		{
			printf("%d:", time / 60);
			if (time % 60 < 10)
				printf("0%d", time % 60);
			else
				printf("%d", time % 60);
			printf(" min/km\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值