POJ 3468 A Simple Problem with Integers (树状数组) (区间修改+区间查询)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 114049 Accepted: 35396
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


区间值 修改,  区间查询;

首先 会超出int  范围 所以用 long long ;

 区间修改 与单点修改不同  

思路:两个数组C1[x]表示该点元素与左边的差值,C2[x]表示的是x*C[x]

 因此:  求区间的和 为 : 


1.  sum(sum(C[j],j<=i)i<=x)  

2.  =(x+1)*sum(C[i],i<=x)-sum(i*C[i],i<=x); 

区间修改[a,b]:   

add(c1,a,num);

     add(c1,b+1,-num);

     add(c2,a,a*num);

     add(c2,b+1,-num*(b+1));

区间求和[a,b]:

ll Get_sum(ll x)

{

    return Sum(x,c1)*x-Sum(x,c2);

}

ll Get(ll a,ll b)

{

    return Get_sum(b+1)-Get_sum(a);// 闭区间从 b+1 ---a;

}


AC代码:

#include <stdio.h>
#include <queue>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
typedef long long ll;
using namespace std;
const int N =1000110;
ll c1[N],c2[N];
ll air[N];
ll n;
void add(ll tree[],ll k,ll num)
{
    while(k<=n)
	{
		tree[k]+=num;
		k+=k&(-k);
	}
}
ll  Sum(ll x,ll tree[])
{
	ll sum=0;
	while(x>0)
	{
		sum+=tree[x];
		x-=x&(-x);
	}
	return sum;
}
ll Get_sum(ll x)
{
    return Sum(x,c1)*x-Sum(x,c2);
}
ll Get(ll a,ll b)
{
    return Get_sum(b+1)-Get_sum(a);
}

int main()
{
    ll q;
    ll x;
    //freopen("input.txt","r",stdin);
    char str[2];
    memset(c1,0,sizeof(c1));
    memset(c2,0,sizeof(c2));
    memset(air,0,sizeof(air));
    scanf("%lld %lld",&n,&q);
    {
        memset(air,0,sizeof(air));
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&x);
            air[i]=air[i-1]+x;

        }
        while(q--)
        {
            ll a,b,c;
            scanf("%s",str);
            if(str[0]=='C')
            {
                scanf("%lld %lld %lld",&a,&b,&c);
                add(c1,a,c);
                add(c1,b+1,-c);
                add(c2,a,a*c);
                add(c2,b+1,-c*(b+1));
            }
            if(str[0]=='Q')
            {
                scanf("%lld %lld",&a,&b);

                ll ans=Get(a,b);
                ans+= air[b]-air[a-1];
                cout<<ans<<endl;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值