SZTU C语言OJ: 【id:403】

题目描述

本题要求编写程序,对输入的一个整数,从高位开始逐位分割并输出它的各位数字。

输入

输入在一行中给出一个整型范围内的非负整数。

输出

从高位开始逐位输出该整数的各位数字,每个数字后面有一个空格。

样例  

样例输入1

123456

样例输出1 

1 2 3 4 5 6 

AC代码 

#include <stdio.h>
#include <math.h>

int main() {
    int a;
    scanf("%d", &a);
    
    if (a == 0) {
        printf("0\n");  // 单独处理输入为0的情况
    } else {
        int count = 0;
        int temp = a;
        
        while (temp > 0) {
            temp = temp / 10;
            count++;
        }

        temp = a;
        
        while (count > 0) {
            int x = temp / (int)pow(10, count - 1);
            printf("%d", x);
            
            if (count > 1) {
                printf(" ");
            } else {
                printf("\n");
            }
            
            temp = temp % (int)pow(10, count - 1);
            count--;
        }
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值