1103. Integer Factorization

1103. Integer Factorization (30)

时间限制
1200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112+ 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
没想到什么好办法,就dfs吧,最好自己写一个pow函数,我把对应的p时n的最大值都存起来了,根据p的值决定ni的最大值。
#include<iostream>
#include<vector>
#include<algorithm>
#include<cmath>

using namespace std;

int n,k,p;
int maxn[8] = { 0, 0, 20, 7, 4, 3, 2, 2 };
vector<int>t;
vector<vector<int>>ans;

int ipow(int k,int p)
{
	int s=1;
	while(p--)
		s=s*k;
	return s;
}
bool cmp(vector<int>x,vector<int>y)
{
	int xs=0;
	for(int i=0;i<x.size();++i)
		xs+=x[i];
	int ys=0;
	for(int i=0;i<y.size();++i)
		ys+=y[i];
	if(xs!=ys)
		return xs>ys;
	else
		return x>y;
		
}
void dfs(int start ,int sum, int count)
{
	for (int i = start; i <= maxn[p]; ++i)
	{   
		int s=sum+ipow(i,p);
		if(s>n)
			return;
		if(count==k&&s<n)
			continue;
		if(count==k&&s==n)
		{
			t.push_back(i);
			ans.push_back(t);
			t.pop_back();
			return;
		}
		t.push_back(i);
		dfs(i,s,count+1);
		t.pop_back();
	}

}
int main()
{
	cin>>n>>k>>p;
	dfs(1,0,1);
	if(ans.empty())
	{
		cout << "Impossible" << endl;   
		return 0;  
	}
	for (int i = 0; i < ans.size(); ++i)
	{   
		reverse(ans[i].begin(), ans[i].end());  
	}   
	sort(ans.begin(), ans.end(), cmp);
	cout<<n<<" = "<<ans[0][0]<<"^"<<p;
	for(int i=1;i<ans[0].size();++i)
		cout<<" + "<<ans[0][i]<<"^"<<p;
	//169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值