1086. Tree Traversals Again

1086. Tree Traversals Again (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
根据push得到前序序列,根据push和pop得到中序序列,然后求一下后序序列。
#include<iostream>
#include<vector>
#include<string>

using namespace std;

vector<int>pre;
vector<int>in;
vector<int>post;
vector<int>tmp;

void getpost(int s1,int e1,int s2,int e2)
{
	if(s1>e1)
		return ;
	int mid;
	for(int i=s2;i<=e2;++i)
		if(in[i]==pre[s1])
			mid=i;
	getpost(s1+1,mid+s1-s2,s2,mid-1);
	getpost(e1-e2+mid+1,e1,mid+1,e2);	
	post.push_back(pre[s1]);
}
int main()
{
	int n;
	cin>>n;
	for(int i=0;i<2*n;++i)
	{
		string op;
		cin>>op;
		if(op.size()==3)
		{
			int num=tmp[tmp.size()-1];
			tmp.pop_back();
			in.push_back(num);
		}
		else
		{
			int num;
			cin>>num;
			pre.push_back(num);
			tmp.push_back(num);
		}
	}
	getpost(0,n-1,0,n-1);
	cout<<post[0];
	for(int i=1;i<post.size();++i)
		cout<<" "<<post[i];
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值