1085. Perfect Sequence

1085. Perfect Sequence (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CAO, Peng

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
脑袋不清醒就会卡。。。二分查找怎么都写不对了,最后终于想好了,所有结束的down都指向满足条件的第一个下标。
最小值的下标从0开始循环,用二分查找找最大值,判断的条件是最小值和最大值除以p的值比较,注意相等的有余数的不同情况。
#include<iostream>
#include<algorithm>
#include<vector>

using namespace std;

int main()
{
	int n,p;
	cin>>n>>p;
	vector<int>s(n);
	for(int i=0;i<n;++i)
		cin>>s[i];
	sort(s.begin(),s.end());
	int maxl=1;
	for(int i=0;i<n;++i)
	{
		int up=n-1;
		int down=i;
		int mid=(up+down)/2;			
		if(s[i]>s[n-1]/p)
		{
			if(maxl<n-i)
				maxl=n-i;
			break;
		}
		while(up>=down)
		{
			mid=(up+down)/2;
			if(s[i]<s[mid]/p)
				up=mid-1;
			else if(s[i]>s[mid]/p)
				down=mid+1;
			else
			{
				down=mid;
				if(s[mid]%p==0)		
					while(down+1<n&&s[i]==s[down+1]/p&&s[down+1]%p==0)
						down++;
				else
					while(down-1>=i&&s[i]==s[down]/p&&s[down]%p!=0)
						down--;
				down++;
				break;
			}
		}
		if(maxl<down-i)
			maxl=down-i;		
	}
	cout<<maxl;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值