HDU 2163

Palindromes

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3185    Accepted Submission(s): 1867


Problem Description

Write a program to determine whether a word is a palindrome. A palindrome is a sequence of characters that is identical to the string when the characters are placed in reverse order. For example, the following strings are palindromes: “ABCCBA”, “A”, and “AMA”. The following strings are not palindromes: “HELLO”, “ABAB” and “PPA”.


 

Input

The input file will consist of up to 100 lines, where each line contains at least 1 and at most 52 characters. Your program should stop processing the input when the input string equals “STOP”. You may assume that input file consists of exclusively uppercase letters; no lowercase letters, punctuation marks, digits, or whitespace will be included within each word.


 

Output

A single line of output should be generated for each string. The line should include “#”, followed by the problem number, followed by a colon and a space, followed by the string “YES” or “NO”.


 

Sample Input

ABCCBA
A
HELLO
ABAB
AMA
ABAB
PPA
STOP


 

Sample Output

#1: YES
#2: YES
#3: NO
#4: NO
#5: YES
#6: NO
#7: NO


 

Source

2008 “Sunline Cup” National Invitational Contest - Warm Up

 

 

 

 

#include <stdio.h>
#include <string.h>
int main()
{
    char a[10055];
    int wbx=0,j;
    for(j=0;j<100;j++)
    {
        gets(a);
        int l=strlen(a);
        int i;
        int sum=0;
        if(strcmp(a,"STOP")==0)  //题目很贼,如果是STOP直接结束了。
        break;
        for(i=0;i<l/2;i++) //
        {
            if(a[i]!=a[l-1-i])   //   判断是不是回文的。如果第i个不等于第l-1-i个,直接跳出。
            break;
        } 
        if(i==l/2)   //  如果此时i==l/2,则为回文。
        printf("#%d: YES\n",++wbx);
        else  //  反之不是。
        printf("#%d: NO\n",++wbx);
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值