HDU 1358 Period

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3749    Accepted Submission(s): 1841


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 


呃。。
题意大意就是,从第二个位置开始,如果前面有相同的循环串,则输出位置此时的位置下表,并且输出循环串的个数。
思路:跑个KMP,(只有某个位置的移动距离与当前位置的相差的值)为当前位置的1/m之一时,并且next数组里面的值不为0时,才有循环串出现。(窝时这样理解的,不知道对不对)。。
上代码。。
#include <stdio.h>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
using namespace std;
#define mod 1000000007
#define inf 0x7f7f7f7f
int Next[1000005];
char s[1000005]; //看好题目,,数组开100W,我开了10WRE了好多次。。
int l;
void getNext()
{
    int i,j;
    i=0;
    j=-1;
    Next[i]=j;
    while(i<l)
    {
        if(j==-1 || s[i]==s[j])
        {
            i++;
            j++;
            Next[i]=j;
        }
        else
            j=Next[j];
    }
}
int main()
{
    int n;
    int Case=0;
    while(cin>>n,n)
    {
        scanf("%s",s);
        l=strlen(s);
        memset(Next,0,sizeof(Next));
        getNext();
        printf("Test case #%d\n",++Case);
        int k;
        // for(k=0;k<l;k++)
        //     cout<<Next[k]<<endl;
        //     cout<<Next[l]<<endl;
        for(k=1; k<l; k++)
        {
            if(Next[k+1]!=0 && (k+1)%(k+1-Next[k+1])==0)  //只有next数组不为0时才有循环节出现,,循环节的长度就是当前的长度减去next数组每次移动的长度。
                cout<<k+1<<" "<<(k+1)/(k+1-Next[k+1])<<endl;
        }
        cout<<endl;
    }
    return 0;
}

所以,求出
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值