HDU 5317

RGCDQ

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1507    Accepted Submission(s): 643


Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know maxGCD(F(i),F(j)) (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query,output the answer in a single line.
See the sample for more details.
 

Sample Input
  
  
2 2 3 3 5
 

Sample Output
  
  
1 1
 

Author
ZSTU
 

Source

 



预处理l带r区间内所有1,2,3,4,5,6,7出现了几次。因为最多就七个因子,然后暴力找一下就好了。

#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <iostream>
using namespace std;
int sum[1000002][8];
int num[1000002];
int main()
{
    memset(num,0,sizeof(num));
    for(int i=2; i<=1000001; i++)
        if(num[i]==0)
            for(int j=i; j<=1000001; j+=i)
                num[j]++;
    memset(sum,0,sizeof(num));
    for(int i=2; i<=1000001; i++)
    {
        for(int j=1; j<=7; j++)
        {
            sum[i][j]=sum[i-1][j];
        }
        sum[i][num[i]]++;
    }
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int l,r;
        scanf("%d%d",&r,&l);
        int s[8];
        for(int i=1; i<=7; i++)
            s[i]=sum[l][i]-sum[r-1][i];
        int ans=1;
        for(int i=1; i<=7; i++)
        {
            if(s[2]+s[4]+s[6]>1)
                ans=max(ans,2);
            if(s[3]+s[6]>1)
                ans=max(ans,3);
            if(s[i]>1)
                ans=max(ans,i);
        }
        printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值