HDU 5124 hihocoder 1249 Xiongnu's Land (2015北京区域赛A)

lines

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1441    Accepted Submission(s): 596


Problem Description
John has several lines. The lines are covered on the X axis. Let A is a point which is covered by the most lines. John wants to know how many lines cover A.
 

Input
The first line contains a single integer   T(1T100) (the data for   N>100  less than 11 cases),indicating the number of test cases.
Each test case begins with an integer   N(1N105) ,indicating the number of lines.
Next N lines contains two integers   Xi  and   Yi(1XiYi109) ,describing a line.
 

Output
For each case, output an integer means how many lines cover A.
 

Sample Input
  
  
2 5 1 2 2 2 2 4 3 4 5 1000 5 1 1 2 2 3 3 4 4 5 5
 

Sample Output
  
  
3 1
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   5566  5565  5564  5561  5560 
 




n个区间,【x.y】哪个点被覆盖最多。

#include <bits/stdc++.h>
#include<algorithm>
using namespace std;
typedef long long ll;
#include <vector>
typedef pair<int,int>p;
vector<p>v;
const int N=1e5+100;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int x,y;
        v.clear();
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            v.push_back(make_pair(x,1));
            v.push_back(make_pair(y+1,-1));
        }
        sort(v.begin(),v.end());
        int max1=0;
        int ans=0;
        for(int i=0; i<v.size(); i++)
        {
            ans+=v[i].second;
            max1=max(max1,ans);
        }
        printf("%d\n",max1);
    }
    return 0;
}



北京区域赛A题。和上面这题很像。求前缀和的前缀和。
#include <iostream>
#include <cstring>
#include <cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
#include <vector>
const int N=1000005;
ll hash1[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int r;
        ll x,y;
        ll l,w;
        scanf("%d",&r);
        int n;
        memset(hash1,0,sizeof(hash1));
        scanf("%d",&n);
        ll sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%lld%lld%lld%lld",&x,&y,&l,&w);
            //cout<<l*w<<endl;
            hash1[x+1]+=w;
            hash1[x+l+1]-=w;
            sum+=l*w;
            // cout<<sum<<endl;
        }

        ll tot=0;
        ll res=0;
        ll min1=999999999999999;
        int op=0;
        for(int i=0; i<=r; i++)
        {
            tot+=hash1[i];
            res+=tot;
            if(2*res-sum>=0)
            {
                // cout<<res<<endl;
                if(2*res-sum<=min1)
                {
                    min1=2*res-sum;
                    op=i;
                }
            }
        }
        cout<<op<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值