【字符串】【hdu2222】AC自动机

AC自动机

一种多模匹配算法(如:有N个字符串Si以及一个字符串T,计算每个字符串Si在T中出现的次数)

原理:KMP+Trie

算法详解ac自动机最详细的讲解,让你一次学会ac自动机

模板

const int C = 26;
const int N = 1e5;
stack <int> st;
 
struct Node {
    int son[C], next, end;
    bool vis;
};

struct AC {
    Node node[N];
    int tol;
	int newNode() // 新建节点
    {
        memset(node[tol].son, 0, sizeof(node[tol].son));
        node[tol].next = 0;
        node[tol].end = 0;
        return tol++;
	}

 	void init() { tol = 0; newNode(); }// 初始化

 	void insert(char s[]) // 插入字符串
 	{
        int cur = 0;
        for(int i = 0; s[i]; i++) 
        {
            int &son = node[cur].son[s[i]-'a'];
            if(!son) son = newNode();
            cur = son;
        }
        node[cur].end++;
	}


    void bfs() //获取计算Next
    {
        queue<int> q;
        for(int i = 0; i < C; i++) if(node[0].son[i]) 		   	      	q.push(node[0].son[i]);
        while(!q.empty()) 
        {
            int fa = q.front();
            q.pop();
            int nex = node[fa].next;
            for(int i = 0; i < C; i++) 
            {
                int& son = node[fa].son[i];
                if(!son) {
                    son = node[nex].son[i];
                    } else {
                    node[son].next = node[nex].son[i];
                    q.push(son);
                    st.push(son);}
            }
        }
    }
    int search(char *s) //字符串匹配
    {
        int l = strlen(s), cur = 0;
        for(int i = 0; i < l; i++) 
        {
            cur = node[cur].son[s[i] - 'a'];
            node[cur].vis = true;
        }
        int ans = 0;
        while(!st.empty()) 
        {
            int cur = st.top();
            if(node[cur].vis) 
                node[node[cur].next].vis = true;        
            st.pop();
        }
        for(int i = 0; i < tol; i++) 
            if(node[i].vis) ans += node[i].end; 
        return ans;
    }
} ;

例题(hdu2222)

Keywords Search

Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input
1 
5
she
he
say
shr
her
yasherhs

Sample Output
3

AC:

#include <iostream>
#include <cstring>
#include <queue>
#include <stack>
using namespace std; 
const int C = 26;
const int N = 1e5;
stack <int> st;
 
struct Node {
    int son[C], next, end;
    bool vis;
};

struct AC {
    Node node[N];
    int tol;
	int newNode() // 新建节点
    {
        memset(node[tol].son, 0, sizeof(node[tol].son));
        node[tol].next = 0;
        node[tol].end = 0;
        return tol++;
	}

 	void init() { tol = 0; newNode(); }// 初始化

 	void insert(char s[]) // 插入字符串
 	{
        int cur = 0;
        for(int i = 0; s[i]; i++) 
        {
            int &son = node[cur].son[s[i]-'a'];
            if(!son) son = newNode();
            cur = son;
        }
        node[cur].end++;
	}

    void bfs() //获取计算Next
    {
        queue<int> q;
        for(int i = 0; i < C; i++) if(node[0].son[i]) 		   	      	q.push(node[0].son[i]);
        while(!q.empty()) 
        {
            int fa = q.front();
            q.pop();
            int nex = node[fa].next;
            for(int i = 0; i < C; i++) 
            {
                int& son = node[fa].son[i];
                if(!son) {
                    son = node[nex].son[i];
                    } else {
                    node[son].next = node[nex].son[i];
                    q.push(son);
                    st.push(son);}
            }
        }
    }
    int search(char s[]) //字符串匹配
    {
        int l = strlen(s), cur = 0;
        for(int i = 0; i < l; i++) 
        {
            cur = node[cur].son[s[i] - 'a'];
            node[cur].vis = true;
        }
        int ans = 0;
        while(!st.empty()) 
        {
            int cur = st.top();
            if(node[cur].vis) 
                node[node[cur].next].vis = true;        
            st.pop();
        }
        for(int i = 0; i < tol; i++) 
            if(node[i].vis) ans += node[i].end; 
        return ans;
    }
}ac;
int main()
{
	int T,t;
	char str[10];
	cin>>T;
	while(T--)
	{
		ac.init();
		cin>>t;
		while(t--)
		{
			cin>>str;
			ac.insert(str); 
		}
		ac.bfs();
		cin>>str;
		cout<<ac.search(str)<<endl; 
	} 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值