hdu1022(stack)

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
Sample Input
3 123 321
3 123 312
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH


        
  
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".


/*题意:给你两个数字串,每个串的长度已知,然后让你判断能否按照栈的方式将第一个串按照第二个串的方式输出

思路:用栈将第一个串读入,每读入一个字符做一次判断判断当前栈顶元素是否为第二个串的n--个元素且保证栈不为空,通过计数法若将第二个串的整个长度遍历说明yes,否则no,至于in,out的输出用一个标记数组即可

*/


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <stack>

using namespace std;

char a[50];
char b[50];
int c[50];

int main()
{
    int n;
    while(scanf("%d", &n) != EOF){
        getchar();
        scanf("%s", a);
        getchar();
        scanf("%s", b);
        memset(c, -1, sizeof(c));
        stack<char>q;
        int k = 0;
        int j = 0;
        for(int i = 0; i < n; i++){
            q.push(a[i]);
            c[k++] = 1;
            while(!q.empty() && q.top() == b[j]){
                c[k++] = 0;
                q.pop();
                j++;
            }
        }
        if(j != n){
            printf("No.\nFINISH\n");
        }
        else{
            printf("Yes.\n");
            for(int i = 0; i < 2*n; i++){
                if(c[i] == 1) printf("in\n");
                if(c[i] == 0) printf("out\n");
            }
            printf("FINISH\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值