The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest &&The Frog's Games

5 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=4004



Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).


Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.


Output
For each case, output a integer standing for the frog's ability at least they should have.


Sample Input
6 1 2
2
25 3 3
11
2
18


Sample Output
4
11
思路:最大值最小化,二分+贪心,这道题很是让我纠结。。。。。。。

#include<iostream>
#include<algorithm>
using namespace std;
#define N 500005
int a[N];
int ll,n,m;
bool dog(int x)
{   int  now=0,step=0;
   for(int i=1;i<=m;++i)//记录当前的步数。
   {     if(a[now+1]-a[now]>x) return false;//先判断能否从当前位置到紧接着的下一个,如果不能则说明该种情况是断路,走不通。
           step=now+1; //如果能从当前位置到下一个位置,则往下继续判断,从而找出从当前位置能到达的最远位置。
          while(a[step]-a[now]<=x)
          {  if(step==n+1)  return true;//如果能走到末尾则返回true
              step++;
          }
          now=--step;//标记从当前位置能到达的最远位置,作为下一次的首位置(当前位置)。
   }
   return false;
 }
 int main()
 {  while(cin>>ll>>n>>m)
 {    for(int i=1;i<=n;i++)
             cin>>a[i];
              a[0]=0;
              a[n+1]=ll;
              sort(a,a+n+2);
        int x=1,y=ll;
        while(x<y)//二分
        {  int mid=(x+y)>>1;
             if(dog(mid)) y=mid;
              else   x=mid+1;
          }
          cout<<y<<endl;
        }return 0;
 }
     
     
     
     

代码二:

#include<iostream>
#include<algorithm>
using namespace std;
#define N 500005
  int p[N];
  int ll,n,m;
  bool f(int len)
  {  int s=len;
      int sum=0;
      while(true)
      {   sum++;
         if(sum>m)  return false;
          if(s>=ll) return true;
          //int tp=upper_bound(p,p+n+2,s)-p;返回第一个不大于大于s的位置 
         int tp=lower_bound(p,p+n+2,s)-p;//返回第一个不小于s的位置 
          if(p[tp]!=s)   tp--;
            s=p[tp]+len;
      }
  }
  int main()
  {   while(cin>>ll>>n>>m)
     {
        for(int i=1;i<=n;i++)
         cin>>p[i];
          p[0]=0;
          p[n+1]=ll;
          sort(p,p+n+2);
          int l=0,r=ll;
          while(l<r)
          {   int mid=(l+r)>>1;
                if(f(mid))
                    r=mid;
                    else l=mid+1;
           }
                    cout<<r<<endl;
             }return 0;
     }



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值