http://poj.org/problem?id=1456&&并查集

67 篇文章 0 订阅
43 篇文章 0 订阅
Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.



Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input

4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10

Sample Output

80

185

AC代码:

#include<stdio.h>           
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#define MAX 10005
using namespace std;
struct product
{
 int a,b;
}A[MAX];
int sun[MAX];
bool operator<(const product &x,const product &y)
{return x.a>y.a;}
int find(int a)   
{
  if(a!=sun[a])
   sun[a]=find(sun[a]);
    return sun[a];
}
int main()
{
  int n,i,sum,flag[MAX],b,max;
  while(scanf("%d",&n)!=EOF)
  { 
   max=0;
    for(i=0;i<n;i++)
   {
  scanf("%d%d",&A[i].a,&A[i].b);
     if(max<A[i].b)
     max=A[i].b;
 }
 for(i=0;i<=max;i++)
    sun[i]=i;
    sort(A,A+n);
    memset(flag,0,sizeof(flag));
      sum=0;
  for(i=0;i<n;i++)
  {
       if(!flag[A[i].b])
    {
     sum+=A[i].a;
     flag[A[i].b]=1;
     sun[A[i].b]=A[i].b-1; 
    }
    else
    {
       b=find(A[i].b);
    if(b)
    {
      sum+=A[i].a;
      flag[b]=1;
      sun[b]=b-1; 
    }
    }
  }
  printf("%d\n",sum);
  }
  return 0;
}

代码二:

#include<stdio.h>           
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#define MAX 10005
#define FOR(i,s,t) for(int i=(s);i<=(t);++i)
using namespace std;
struct product
{
 int a,b;
}A[MAX];
int sun[MAX];
bool operator<(const product &x,const product &y)
{return x.a>y.a;}
int find(int a)   
{
  //if(a!=sun[a])
   //sun[a]=find(sun[a]);
    //return sun[a];
    while(a!=sun[a])
      a=sun[a];
      return a;
}
int main()
{
  int n,flag[MAX],m;
  while(scanf("%d",&n)!=EOF)
  { 
   m=0;
   FOR(i,0,n-1)
   {
  scanf("%d%d",&A[i].a,&A[i].b);
     m=max(m,A[i].b);
 }
 FOR(i,0,m)
    {sun[i]=i;
     flag[i]=0;
     }
    sort(A,A+n);
      int sum=0;
      FOR(i,0,n-1)
  {
       if(!flag[A[i].b])
    {
     sum+=A[i].a;
     flag[A[i].b]=1;
     sun[A[i].b]=A[i].b-1; 
    }
    else
    {
       int b=find(A[i].b);
    if(b)
    {
      sum+=A[i].a;
      flag[b]=1;
      sun[b]=b-1; 
    }
    }
  }
  printf("%d\n",sum);
  }
  return 0;
}

思路:首先按利润从大到小排序,然后判断在该物品卖出的截止日期,如果截止日期已被占用,就向前寻找。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,这个问题属于技术问题。以下是一个简单的Python模拟登录POJ提交代码并抓取评测结果的代码示例: ```python import requests # 登录POJ,获取cookie def login(username, password): s = requests.Session() login_url = "http://poj.org/login" login_data = { "user_id1": username, "password1": password, "B1": "login", "url": "/" } s.post(login_url, data=login_data) return s # 提交代码 def submit_code(s, problem_id, language, source_code): submit_url = "http://poj.org/submit" submit_data = { "problem_id": problem_id, "language": language, "source": source_code } s.post(submit_url, data=submit_data) # 获取评测结果 def get_result(s, run_id): status_url = "http://poj.org/status" params = { "user_id": "", "result": "", "language": "", "top": run_id } r = s.get(status_url, params=params) table_start = r.text.find("<table cellpadding=0 cellspacing=0 border=0 width=100%>") table_end = r.text.find("</table>", table_start) table_html = r.text[table_start:table_end + 8] return table_html # 使用示例 username = "your_username" password = "your_password" problem_id = "1000" language = "G++" source_code = """ #include <iostream> using namespace std; int main() { int a, b; cin >> a >> b; cout << a + b << endl; return 0; } """ s = login(username, password) submit_code(s, problem_id, language, source_code) table_html = get_result(s, "12345678") # 替换成实际提交的run id print(table_html) ``` 其中,`login`函数模拟登录POJ并返回一个`Session`对象,`submit_code`函数提交代码,`get_result`函数获取评测结果。你可以根据实际需要修改代码中的`username`、`password`、`problem_id`、`language`和`source_code`等参数,并替换`get_result`函数中的`run_id`。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值