http://poj.org/problem?id=1961

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input

3
aaa
12
aabaabaabaab
0
Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3

12 4

这道题得题意是先给你一个数,表示输入字符串的长度,然后依次从第二个字符开始作为匹配字符的结束求对应的匹配字符串的周期,输出匹配字符串的长度以及其对应的周期,且周期大于1.

代码:

#include<iostream>
#include<cstdio>
#define N 1000002
using namespace std;
int next[N];
char str[N];
int main()
{ int n=1,len;
  while(cin>>len&&len)
  {  scanf("%s",str);
      next[1]=0;表示第一个字符的部分匹配串长度为0
      int j=0;
      for(int i=2;i<=len;++i)
        {     while(j>0&&str[j]!=str[i-1]) 
                      j=next[j];当前字符不匹配,字符串向右移动,
              if(str[j]==str[i-1]) j++;
                next[i]=j;记录当前字符的部分匹配串的长度。
              }
              printf("Test case #%d\n",n++);
              for(int k=2;k<=len;k++)  求字符串向右移动的位数。
                if(k%(k-next[k])==0&&k/(k-next[k])!=1)
                printf("%d %d\n",k,k/(k-next[k]));
                if(n<=len) printf("\n");  
                      } return 0;
    }

代码:

#include<iostream>
#include<cstdio>
#define N 1000002
using namespace std;
int next[N];
char str[N];
int main()
{ int n=1,len;
  while(cin>>len&&len)
  {  scanf("%s",str);
      next[1]=0;
      int j=0,i=2;
       while(i<=len)
        {    if(str[i-1]==str[j])
               {  next[i]=j+1;
                  i++;j++;
                  }
                  else{  if(j>0) j=next[j];
                         else next[i++]=0;
                       }
              }
              printf("Test case #%d\n",n++);
               for(int k=1;k<=len;++k)
                if(k%(k-next[k])==0&&k/(k-next[k])!=1)
                printf("%d %d\n",k,k/(k-next[k]));
                if(n<=len) printf("\n");  
                      } return 0;
    }



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值