http://acm.hdu.edu.cn/showproblem.php?pid=1116&&Play on Words

Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list. 
 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 
 

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.
题意:就是给你一些单词,判断是否可以首尾相接,易知可以转化为欧拉问题,要想满足上述要求可知该图必须为欧拉图或者存在欧拉通路。
思路:无向图中:图为欧拉图的判定条件为所有顶点都是偶度顶,存在欧拉通路的条件有且仅有两个奇度顶。
有向图中:图为欧拉图的判定条件为所有顶点的入度都等于出度,存在欧拉通路的条件是存在2个顶点,其中一个顶点的入度比出度大一,另一个出度比入度大一。
AC代码:
#include<iostream>
#include<string.h>
#include<string>
#include<cstdio>
#include<algorithm>
#define N 26
using namespace std;
int Father[N];
int In[N];
int Out[N];
int p[N];
bool vis[N];
void init()
{
    for(int i=0;i<N;++i) Father[i]=i;
    memset(In,0,sizeof(In));
    memset(Out,0,sizeof(Out));
    memset(vis,false,sizeof(vis));
}
int Find(int x)
{
    if(x==Father[x]) return x;
    else return Father[x]=Find(Father[x]);
}
void Union(int a,int b)
{
    int x=Find(a);
    int y=Find(b);
    if(x!=y)
    { 
        Father[x]=y;
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        init();
        int n;
        scanf("%d",&n);
        string s;
        for(int i=0;i!=n;++i)
        {
            cin>>s;
            int a=s[0]-'a';
            int b=s[s.size()-1]-'a';
            Union(a,b);
            Out[a]++;
            In[b]++;
            
            vis[a]=true;
            vis[b]=true;
        }
        int res=0;
        for(int i=0;i<26;++i)
            if(vis[i]&&Find(i)==i) res++;
        if(res>1) {printf("The door cannot be opened.\n");continue;}//图不连通
         int cnt=0;
         for(int i=0;i<26;++i)
             if(vis[i]&&In[i]!=Out[i]) p[cnt++]=i;
         if(cnt==0) {printf("Ordering is possible.\n"); continue;}//欧拉回路
         if(cnt==2&&(Out[p[0]]-In[p[0]]==1&&In[p[1]]-Out[p[1]]==1||Out[p[1]]-In[p[1]]==1&&In[p[0]]-Out[p[0]]==1))           
		 {  printf("Ordering is possible.\n");continue;}//欧拉通络
         printf("The door cannot be opened.\n");
    }return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值