POJ3259——Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 43888 Accepted: 16117

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2         //T组测试数据
3 3 1     //n个农场,m条路,w个洞
1 2 2     //(m行) a->b  需要time
1 3 4
2 3 1
3 1 3     //(w行) 洞  a->b  时间倒流time
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO      //没有负环  NO   有负环  YES
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source


有n个农场,问  从 i  点出发,最后回到 i  点  所花的时间是否为负值, 是  就输出YES,否则输出NO;

也就是说判断图中是否有负环的问题    有 YES  无  NO

 

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <algorithm>

using namespace std;

struct node
{
    int x,y;
    int time;
}mp[2705];             //结构体储存从x到y所需要的时间

int n, m, w;
const int inf = 0x3f3f3f3f;

int bellman()
{
    int dis[510], flag = 1, cnt = 1;
    for( int i = 1;i <= 510;i++ )
        dis[i] = inf;

    while(flag)
    {
        flag = 0;
        if( cnt++>n ) return 1;
        int i;
        for( i = 1;i <= m;i++ )                    //遍历路径
        {
            if( dis[mp[i].x] + mp[i].time<dis[mp[i].y] )     //到y的最短时间大于从x到y的时间  则更新
            {
                dis[mp[i].y] = dis[mp[i].x] + mp[i].time;
                flag = 1;
            }
            if( dis[mp[i].y] + mp[i].time<dis[mp[i].x] )   //同理
            {
                dis[mp[i].x] = dis[mp[i].y] + mp[i].time;
                flag = 1;
            }
        }
        for( ;i <= m+w;i++ )  //遍历虫洞
        {
            if( dis[mp[i].y] > dis[mp[i].x] - mp[i].time )
            {
                dis[mp[i].y] = dis[mp[i].x] - mp[i].time;
                flag = 1;
            }
        }
    }
    return 0;
}

int main()
{
    int T;
    cin>>T;
    while( T-- )
    {
        cin>>n>>m>>w;
        for( int i = 1;i <= m + w;i++ )
        {
            cin>>mp[i].x>>mp[i].y>>mp[i].time;
        }
        if( bellman() )
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值