POJ3267——The Cow Lexicon

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9558 Accepted: 4585

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L
Line 2:  L characters (followed by a newline, of course): the received message
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source


题目大意:

现有一个长度为L的字符串,已知W个单词,问最少删除多少个字母之后,字符串能变为单词的组合;

思路:

DP题;


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

int w, l;
char dir[610][310];
int len[610];
char str[310];
int step[310];

int dp()
{

    step[0] = 1;
    for( int i = 1;i < l;i++ )
    {
        step[i] = step[i-1]+1;
        for( int j = 1;j <= w;j++ )
        {
            int x = len[j] - 1, y = i;
            if( x>y ) continue;
            while( x>=0&&y>=0&&x<=y )
            {
                if( str[y]==dir[j][x] )
                    x--;
                y--;
            }
            if( x<0 )
                step[i] = min(step[i], step[y] + i - y - len[j]);
        }
    }
    return step[l-1];
}

int main()
{
    cin>>w>>l;
    cin>>str;
    for( int i = 1;i <= w;i++ )
    {
        cin>>dir[i];
        getchar();
        len[i] = strlen(dir[i]);
    }

    cout<<dp()<<endl;

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值