Longest Ordered Subsequence
Description
A numeric sequence of
ai is ordered if
a1 <
a2 < ... <
aN. Let the subsequence of the given numeric sequence (
a1,
a2, ...,
aN) be any sequence (
ai1,
ai2, ...,
aiK), where 1 <=
i1 <
i2 < ... <
iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence. Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input 7 1 7 3 5 9 4 8 Sample Output 4 Source
Northeastern Europe 2002, Far-Eastern Subregion
|
题目大意:
就是求最长上升子序列。。。非常裸的一个题。。。
#include <iostream>
using namespace std;
int main()
{
int n;
cin>>n;
int *a = new int[n+1];
for( int i = 1;i <= n;i++ )
cin>>a[i];
int *len = new int[n+1];
for( int i = 1;i <= n;i++ )
len[i] = 1;
for( int i = 1;i <= n;i++ )
{
int mx = 0;
for( int j = 1;j <= i-1;j++ )
{
if( a[i]>a[j]&&mx<len[j] )
mx = len[j];
}
len[i] = mx + 1;
}
int mx= 0;
for( int i = 1;i <= n;i++ )
{
if( len[i]>mx )
mx = len[i];
}
cout<<mx<<endl;
return 0;
}