POJ1942——Paths on a Grid

Paths on a Grid
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 24783 Accepted: 6154

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b) 2=a 2+2ab+b 2). So you decide to waste your time with drawing modern art instead. 

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 

Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126
2

Source


题目大意:

给你一个 n * m 的方格,沿着网格线从左下角出发到右上角,每次只能向上或向右走,求一共有多少种走法。

思路:

无论怎么走,最终结果就是向上走 m 个单位,向右走 n 个单位,总共走 n+m 个单位,所以此时问题简化为  C(n+m,n) 的问题,

题目给的是  two unsigned 32-bit integers n and m,无符号变量,如果直接套用公式肯定不行,long long都不够,所以这里做了一下简化,比如:

n = 5,m = 2;


由于用了 double去计算组合数,那么最后要转化为 无符号整型 时就要处理精度问题,有两种方法:四舍五入+强制类型转换  或者 用 setprecision()函数

下面的程序给出的是第一种方法,第二种方法的输出为

cout<<fixed<<setprecision(0)<<C(n,m)<<endl;
//fixed是为了固定小数位数
//setprecision()函数是会自动四舍五入的,所以不用像强制类型转换那样预先+0.5  

    //Source Code
    //Memory: 728K		Time: 16MS
    //Language: G++	Result: Accepted

    #include <iostream>
    #include <algorithm>

    using namespace std;

    unsigned C(unsigned a, unsigned b)
    {
        unsigned x = a+b;
        unsigned y = (a>b?b:a);
        double sum = 1.0;
        while( y>0 )
        {
            sum *= (double)(x--)/(double)(y--);
        }
        sum += 0.5;             //<span style="font-family: Consolas, 'Courier New', Courier, mono, serif; line-height: 18px; background-color: rgb(248, 248, 248);">double转unsigned会强制截断小数,必须先四舍五入</span>
        return (unsigned)sum;
    }

    int main()
    {
        long long a, b;
        while( cin>>a>>b )
        {
            if( !a&&!b )
                break;
            cout<<C(a,b)<<endl;
        }

        return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值