Wireless Network

这道题目可能数据比较水

这道题目只要是两台电脑的距离小于d就视为在同一并查集中

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<iostream>
void p(int a);
void mer(int a,int b);
int find(int a);
int pre[1005];
bool re[1005];
int main()
{
	int n,i,j;
	double d,an[1005][2]={0};
	memset(re,0,sizeof(re));
	scanf("%d%lf",&n,&d);
	p(n);
	for(i=1;i<=n;i++)
	{
		scanf("%lf%lf",&an[i][0],&an[i][1]);
	}
	char op;
	getchar();
	while(scanf("%c",&op)!=EOF)
	{
		int p,q;
		if(op=='O')
		{
			double x,y;
			scanf("%d",&p);
			re[p]=true;
			for(i=1;i<=n;i++)
			{
				if(i!=p&&re[i]==true)
				{
					if(find(p)==find(i))
						continue;
					x=an[p][0]-an[i][0];
					y=an[p][1]-an[i][1];
					if(d-sqrt(x*x+y*y)>=0)
					{
						mer(find(p),i);
					}
				}
			}
		}
		else if(op=='S')
		{
			int fp,fq;
			scanf("%d%d",&p,&q);
			fp=find(p);
			fq=find(q);
			if(fp==fq)
				printf("SUCCESS\n");
			else
				printf("FAIL\n");
		}
		getchar();
	}
	return 0;	
}
void p(int a)
{
	int i;
	for(i=0;i<=a;i++)
	{
		pre[i]=i;
	}
}
void mer(int a,int b)
{
	int fa,fb;
	fa=find(a);
	fb=find(b);
	if(fa!=fb)
		pre[fa]=fb;
}
int find(int a)
{
	int r;
	r=a;
	while(r!=pre[r])
		r=pre[r];
	while(a!=pre[a])
	{
		int z;
		z=a;
		a=pre[a];
		pre[z]=r;
	}
	return r;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值