Cash Machine

这道题会卡普通多重背包的时间,所以需要进行优化,我用的是二进制优化的多重背包,这种方法的主要思想是把多重背包变为01背包,比如,k个大小为w价值为v的物品,照着最简单的方法,就是1*w,1*v为一类,2*w,2*v为一类,……k*w,k*v为一类但是这样的时间效率和之前多重背包的并没有区别,然而你可能发现似乎并不需要这么多类的物品,比如,3*w,3*v可以由1*w,1*v和2*w,2*v相加得到,那么如何得到这些构成其他数字的基础数字,就需要利用二进制的特性,7(十进制)=111(二进制),则1,2,4可以构成7以内(包括7)的所有正整数,13(十进制)=1101(二进制),则1,2,4,6可以构成13以内(包括13)的所有正整数(6=13-1-2-4),用这样的方法就可以缩减时间

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 
Sample Input
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define maxc 100005
using namespace std;
int main()
{
	int cash;
	while(scanf("%d",&cash)!=EOF)
	{
		int n,tail=0,dk[maxc]={0},dp[maxc]={0};
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			int a,b,num=1;
			scanf("%d%d",&a,&b);
			for(int j=1;j<=a;j<<=1)
			{
				dk[tail++]=j*b;
				a-=j;
			}
			if(a>0)
				dk[tail++]=a*b;
		}			
		for(int i=0;i<tail;i++)
			for(int j=cash;j>=dk[i];j--)
					dp[j]=max(dp[j],dp[j-dk[i]]+dk[i]);
		printf("%d\n",dp[cash]);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值