Square

Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
这道题目时间卡的很严,并且是所有长度都要用到,而且不需要对长度排序(更省时间)

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int m,an[100],total;
bool flag;
bool vis[100];
void dfs(int num,int len,int start)
{
	if(flag)
		return ;
	if(num==4)
	{
		flag=1;
		return ;
	}
	if(len==total)
	{
		dfs(num+1,0,0);
		if(flag)
			return ;
	}			
	for(int i=start;i<m;i++)
	{
		if(!vis[i]&&len+an[i]<=total)
		{
			vis[i]=true;
			dfs(num,len+an[i],i+1);
			vis[i]=false;
			if(flag)
				return ;
		}			
	}
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		int sum=0,len=0;
		memset(vis,false,sizeof(vis));
		scanf("%d",&m);
		for(int i=0;i<m;i++)
		{
			scanf("%d",&an[i]);
			sum+=an[i];
			if(an[i]>len)
				len=an[i];
		}
		if(sum%4!=0||len>sum/4)
		{
			printf("no\n");
			continue;
		}				
		flag=0,total=sum/4;
		dfs(0,0,0);			
		if(flag)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值