Friends

Friends

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m n×(n-1)/2, 0 ≤ k n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < n, ui ≠ vi) indicating there is friendship between person ui and vi.


Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0



Sample Output

 
 
2 0 4
这道题目纯暴力能过
先说说暴力的思路吧
对于图中的两个点i,j ,如果存在点l可以使得i,j联通,则将计数器加一,如果计数器的值大于等于k,则将i,j用边连接起来,只要有新边增加就重复上述操作,最后求新增边的条数
#include<iostream>
using namespace std;
int main()
{
	int t;
	cin >> t;
	while(t--)
	{
		int n,m,k,flag=1,edge=0;
		int rel[105][105]={0}; 
		cin >> n >> m >> k;
		for(int i=0;i<m;i++)
		{
			int u,v;
			cin >> u >> v;
			rel[u][v]=1;
			rel[v][u]=1;
		}
		while(flag)
		{
			flag=0;
			for(int i=0;i<n;i++)
			{
				for(int j=i+1;j<n;j++)
				{
					int sum_friend=0;
					if(rel[i][j])
						continue;
					for(int l=0;l<n;l++)
					{
						if(rel[i][l]&&rel[l][j])
							sum_friend++;
					}					
					if(sum_friend>=k)
					{
						rel[i][j]=1;
						rel[j][i]=1;
						flag=1;
						edge++;
						break;
					}
				}
			}
		}
		cout << edge << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值