Roadblocks

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers:  N and  R 
Lines 2..  R+1: Each line contains three space-separated integers:  AB, and  D that describe a road that connects intersections  A and  B and has length  D (1 ≤  D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node  N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450
Hint
Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
只会暴力,然后各种超时

这道题目需要用两次最短路(spfa,dijkstra都行)

第一次从起点开始,第二次从终点开始,分别记录两点到其他点的最短距离

然后就用其他点去增长那条从起点到终点的那条最短路径

橙色为最短路径,所谓的增长路径就是绿色的那条



#include<cstring>
#include<queue>
#include<iostream>
#include<algorithm> 
#define maxr 100005
#define maxn 5005
#define LL long long
using namespace std;

int n,r,cnt=0;
int head[maxn];
bool inq[maxn];

struct Edge
{
	int u,v,w,next;
}edge[maxr*2];

void add_edge(int u,int v,int w)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].w=w;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
void spfa(int s,LL *dis)
{
	queue<int> q;
	memset(inq,0,sizeof(inq));
	fill(dis,dis+n+1,1e9);
	q.push(s);
	inq[s]=true;
	dis[s]=0;
	while(!q.empty())
	{
		int Q=q.front();
		q.pop();
		inq[Q]=false;
		for(int i=head[Q];i!=-1;i=edge[i].next)
		{
			int to=edge[i].v;
			if(dis[to]>dis[Q]+edge[i].w)
			{
				dis[to]=dis[Q]+edge[i].w;
				if(!inq[to])
				{
					q.push(to);
					inq[to]=true;
				}
			}
		}
	}
}
int main()
{
	LL len,ans=1e9;
	LL dis_1[maxn],dis_n[maxn];
	while(cin >> n >> r)
	{
		cnt=0;
		memset(head,-1,sizeof(head));
		memset(edge,0,sizeof(edge));
		for(int i=0;i<r;i++)
		{
			int a,b,c;
			cin >> a >> b >> c;
			add_edge(a,b,c);
			add_edge(b,a,c); 
		}
		spfa(1,dis_1);
		spfa(n,dis_n);
		len=dis_1[n];
		for(int i=0;i<cnt;i++)          //因为这里是无向图(即边是双向的),所以要循环2n次 
		{
			int u=edge[i].u,v=edge[i].v,w=edge[i].w; 
			if(dis_1[u]+dis_n[v]+w>len)
			{
				ans=min(ans,dis_1[u]+dis_n[v]+w);
			}
		}
		cout << ans << endl;
	}	
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值