hdu4901 The Romantic Hero 2014 Multi-University Training Contest 4

The Romantic Hero

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 693    Accepted Submission(s): 285


Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

You may wonder why this country has such an interesting tradition? It has a very long story, but I won't tell you :).

Let us continue, the party princess's knight win the algorithm contest. When the devil hears about that, she decided to take some action.

But before that, there is another party arose recently, the 'MengMengDa' party, everyone in this party feel everything is 'MengMengDa' and acts like a 'MengMengDa' guy.

While they are very pleased about that, it brings many people in this kingdom troubles. So they decided to stop them.

Our hero z*p come again, actually he is very good at Algorithm contest, so he invites the leader of the 'MengMengda' party xiaod*o to compete in an algorithm contest.

As z*p is both handsome and talkative, he has many girl friends to deal with, on the contest day, he find he has 3 dating to complete and have no time to compete, so he let you to solve the problems for him.

And the easiest problem in this contest is like that:

There is n number a_1,a_2,...,a_n on the line. You can choose two set S(a_s1,a_s2,..,a_sk) and T(a_t1,a_t2,...,a_tm). Each element in S should be at the left of every element in T.(si < tj for all i,j). S and T shouldn't be empty.

And what we want is the bitwise XOR of each element in S is equal to the bitwise AND of each element in T.

How many ways are there to choose such two sets? You should output the result modulo 10^9+7.
 

Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains a integers n.
The next line contains n integers a_1,a_2,...,a_n which are separated by a single space.

n<=10^3, 0 <= a_i <1024, T<=20.
 

Output
For each test case, output the result in one line.
 

Sample Input
  
  
2 3 1 2 3 4 1 2 3 3
 

Sample Output
  
  
1 4
 

Author
WJMZBMR
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4906  4904  4903  4902  4901 
 

dp思想 做两遍dp 分别求从左到右亦或所能到达的值的次数,以及从右到左与运算能到达的值的次数

dp1[i][j]为前i项亦或结果为j的情况数,dp2[i][j]为从n到i的,最后乘一下就好了

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int mod=1000000007;
typedef long long ll;
ll dp1[1004][2050];
ll dp2[1004][2050];
int c[1010];
int main()
{
    int T,n,x;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        memset(dp1,0,sizeof(dp1));
        memset(dp2,0,sizeof(dp2));
        int ma=-1,t;
        for(int i=1;i<=n;i++){
            scanf("%d",&c[i]);
            ma=max(ma,c[i]);
            if(i==n) break;
            dp1[i][c[i]]++;
            t=min(ma*2,2048);
            for(int j=0;j<=t;j++){
                dp1[i][j]=(dp1[i][j]+dp1[i-1][j]+dp1[i-1][j^c[i]])%mod;
            }
        }
        for(int i=n;i>=2;i--){
            dp2[i][c[i]]++;
            for(int j=0;j<=t;j++){
                dp2[i][j]+=dp2[i+1][j];
                dp2[i][j&c[i]]=(dp2[i][j&c[i]]+dp2[i+1][j])%mod;
            }
        }
        ll ans=0;
        for(int i=2;i<=n;i++){
            for(int j=0;j<=t;j++){
                ans=(ans+dp1[i-1][j]*(dp2[i][j]-dp2[i+1][j]))%mod;
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值