hdu4906 Our happy ending 2014 Multi-University Training Contest 4

Our happy ending

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 703    Accepted Submission(s): 225


Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

Y*wan still remember the day he first meets the devil. Now everything is done and the devil is gone. Y*wan feel very sad and suicide.

You feel guilty after killing so many loli, so you suicide too.

Nobody survive in this silly story, but there is still some hope, because this is just a silly background story during one programming contest!

And the last problem is:

Given a sequence a_1,a_2,...,a_n, if we can take some of them(each a_i can only be used once), and they sum to k, then we say this sequence is a good sequence.

How many good sequence are there? Given that each a_i is an integer and 0<= a_i <= L.

You should output the result modulo 10^9+7.
 

Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains 3 integers n, k, L.

T<=20, n,k<=20 , 0<=L<=10^9.
 

Output
For each cases, output the answer in a single line.
 

Sample Input
  
  
1 2 2 2
 

Sample Output
  
  
6
 

Author
WJMZBMR
 

Source
 

Recommend
 
用到状态压缩,代码不长

比赛的时候看了一眼,不会做,赛后参考了神牛的思路http://www.cnblogs.com/L-Ecry/p/3883555.html

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int mod=1e9+7;
int dp[(1<<20)+10];
int main(){
    int T,N,K,L;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d%d",&N,&K,&L);
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        int t=max(L-K,0);
        if(t==L-K)L=K;
        for(int i=0;i<N;i++){
            for(int j=(1<<K)-1;j>=0;j--){
                if(dp[j]==0)continue;
                int temp=dp[j];
                int p=t*1ll*dp[j]%mod;//这个地方不转换成ll会wa
                for(int l=L;l>=1;l--){
                    int s=j|(1<<(l-1))|((j<<l)&((1<<K)-1));
                    dp[s]=(dp[s]+temp)%mod;
                }
                dp[j]=(p+dp[j])%mod;
            }
        }
        int ans=0;
        for(int i=(1<<K-1);i<(1<<K);i++)ans=(ans+dp[i])%mod;
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值