hdu 4937 Lucky Number 2014 Multi-University Training Contest 7

Lucky Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 211    Accepted Submission(s): 55


Problem Description
“Ladies and Gentlemen, It’s show time! ”

“A thief is a creative artist who takes his prey in style... But a detective is nothing more than a critic, who follows our footsteps...”

Love_Kid is crazy about Kaito Kid , he think 3(because 3 is the sum of 1 and 2), 4, 5, 6 are his lucky numbers and all others are not. 

Now he finds out a way that he can represent a number through decimal representation in another numeral system to get a number only contain 3, 4, 5, 6. 

For example, given a number 19, you can represent it as 34 with base 5, so we can call 5 is a lucky base for number 19. 

Now he will give you a long number n(1<=n<=1e12), please help him to find out how many lucky bases for that number. 

If there are infinite such base, just print out -1.
 

Input
There are multiply test cases.

The first line contains an integer T(T<=200), indicates the number of cases. 

For every test case, there is a number n indicates the number.
 

Output
For each test case, output “Case #k: ”first, k is the case number, from 1 to T , then, output a line with one integer, the answer to the query.
 

Sample Input
  
  
2 10 19
 

Sample Output
  
  
Case #1: 0 Case #2: 1
Hint
10 shown in hexadecimal number system is another letter different from ‘0’-‘9’, we can represent it as ‘A’, and you can extend to other cases.
 

Author
UESTC
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4944  4943  4942  4941  4940 
 

比赛时怎么也没想到要特殊处理,就纠结于数据太大了
特殊处理只有1 2 3 位的情况 然后暴力枚举,数据量最大不会超过7000。
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
int ans;
int main()
{
    int T;
    long long n;
    scanf("%d",&T);
    int cas=1;
    while(T--){
        ans=0;
        scanf("%I64d",&n);
        if(n>=3&&n<=6){
            printf("Case #%d: -1\n",cas++);
            continue;
        }
        for(int i=3;i<=6;i++)
            for(int j=3;j<=6;j++)
                if(n>i&&(n-i)%j==0&&(n-i)/j>i&&(n-i)/j>j)ans++;
        for(int i=3;i<=6;i++){
            for(int j=3;j<=6;j++){
                for(int k=3;k<=6;k++){
                    long long p=j*j-4*i*(k-n);
                    if(p>0){
                        long long q=sqrt(p);
                        if(q*q==p){
                            if((-j+q)%(2*i)==0)
                                   if((-j+q)/(2*i)>max(i,max(j,k)))ans++;
                        }
                    }
                }
            }
        }
        long long t,i;
        for(i=4;i*i*i<=n;i++){
            t=n;
            while(t){
                if(t%i<3||t%i>6)break;
                t/=i;
            }
            if(!t)ans++;
        }
        printf("Case #%d: %d\n",cas++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值