UVA 10361

A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form

s1<s2>s3<s4>s5

 

where the si are possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines will we at most 100 characters long.

Output

For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<” and “>” are removed. Line c2 is the same as l2 , except that instead of the three dots the string s4s3s2s5 should appear.

Sample Input

3

ein kind haelt seinen< schn>abel <n>ur

wenn es haengt an der ...

weil wir zu spaet zur<> oma <k>amen

verpassten wir das ...

<d>u <b>ist

...

Sample Output

ein kind haelt seinen schnabel nur

wenn es haengt an der nabel schnur

weil wir zu spaet zur oma kamen

verpassten wir das koma amen

du bist

bu dist


代码

#include<stdio.h>
#include<string.h>
#define N 100  
int main (){
    int i,j,Case,len;
    char a[N],b[N],s[N],s1[N],s2[N],s3[N],s4[N],s5[N];
    while(scanf("%d\n",&Case) != EOF){
        while(Case--){
            gets(a);
            gets(b);
            len = strlen(a);
            for(j = 0,i = 0;a[i] != '<';i++,j++){
                s1[j] = a[i];
            }
            s1[j] = '\0';
            for(i = i+1,j = 0;a[i] != '>';i++,j++){
                s2[j] = a[i];
            }
            s2[j] = '\0';
            for(i = i+1,j = 0;a[i] != '<';i++,j++){
                s3[j] = a[i];
            }
            s3[j] = '\0';
            for(i = i+1,j = 0;a[i] != '>';i++,j++){
                s4[j] = a[i];
            }
            s4[j] = '\0';
            for(i = i+1,j = 0;i < len;i++,j++){
                s5[j] = a[i];
            }
            s5[j] = '\0';
            for(i = 0,j = 0;b[i] != '.';i++,j++){
                s[j] = b[i];
            }
            s[j] = '\0';
            printf("%s%s%s%s%s\n",s1,s2,s3,s4,s5);
            printf("%s%s%s%s%s\n",s,s4,s3,s2,s5);
        }
    }
    return 0;



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值