【杭电2015年12月校赛E】【二进制拆分】Bitwise Equations 第K小的X满足X或Y=X+Y

Bitwise Equations

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 657    Accepted Submission(s): 352


Problem Description
You are given two positive integers X and K. Return the K-th smallest positive integer Y, for which the following equation holds: X + Y =X | Y
Where '|' denotes the bitwise OR operator.
 

Input
The first line of the input contains an integer T (T <= 100) which means the number of test cases.  
For each case, there are two integers X and K (1 <= X, K <= 2000000000) in one line.
 

Output
For each case, output one line containing the number Y.
 

Sample Input
  
  
3 5 1 5 5 2000000000 2000000000
 

Sample Output
  
  
2 18 16383165351936
 


#include<stdio.h>
#include<string.h>
int casenum,casei;
typedef long long LL;
LL b[70];
int main()
{
    for(int i=0;i<63;++i)b[i]=1ll<<i;
    scanf("%d",&casenum);
    for(casei=1;casei<=casenum;++casei)
    {
		LL X,K;
        scanf("%lld%lld",&X,&K);
        LL ans=0;
		int p=0;
        for(int i=0;i<63;++i)if(!(X&b[i]))
        {
            if(K&b[p++])ans|=b[i];
        }
        printf("%lld\n",ans);
    }
    return 0;
}
/*
【trick&&吐槽】
X和K最多只有31个二进制位
所以,答案最多只会有62个二进制位。
用LL就可以AC~

【题意】
有T(100)组数据,
对于每组数据,给定X,K(1<=X,K<=2e9)
让你求出,满足X+Y==X|Y的第K小的Y

【类型】
二进制拆分

【分析】
很显然, X+Y==X|Y的Y,需要满足的性质是——
X二进制是1的位置,Y必须是0;

于是,我们扫描所有X为0的位置,
在这些位置填充一个数值为K的二进制数即可。
具体实现,可以通过模拟代码慢慢体会~

【时间复杂度&&优化】
O(log(X))

*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值