【HDU6195 2017 ACM ICPC Asia Regional Shenyang Online B】【水题 匹配】cable cable cable M个格子任选K个放K个物品的最小连边匹配

cable cable cable

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 152    Accepted Submission(s): 131


Problem Description
Connecting the display screen and signal sources which produce different color signals by cables, then the display screen can show the color of the signal source.Notice that every signal source can only send signals to one display screen each time. 
Now you have  M  display screens and  K  different signal sources( KM2321 ). Select  K  display screens from  M  display screens, how many cables are needed at least so that **any**  K  display screens you select can show exactly  K  different colors.
 

Input
Multiple cases (no more than  100 ), for each test case:
there is one line contains two integers  M  and  K .
 

Output
Output the minimum number of cables  N .
 

Sample Input
  
  
3 2 20 15
 

Sample Output
  
  
4 90
Hint
As the picture is shown, when you select M1 and M2, M1 show the color of K1, and M2 show the color of K2. When you select M3 and M2, M2 show the color of K1 and M3 show the color of K2. When you select M1 and M3, M1 show the color of K1.
 

Source
 

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
#include<ctype.h>
#include<math.h>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<bitset>
#include<algorithm>
#include<time.h>
using namespace std;
void fre() { freopen("c://test//input.in", "r", stdin); freopen("c://test//output.out", "w", stdout); }
#define MS(x, y) memset(x, y, sizeof(x))
#define ls o<<1
#define rs o<<1|1
typedef long long LL;
typedef unsigned long long UL;
typedef unsigned int UI;
template <class T1, class T2>inline void gmax(T1 &a, T2 b) { if (b > a)a = b; }
template <class T1, class T2>inline void gmin(T1 &a, T2 b) { if (b < a)a = b; }
const int N = 0, M = 0, Z = 1e9 + 7, inf = 0x3f3f3f3f;
template <class T1, class T2>inline void gadd(T1 &a, T2 b) { a = (a + b) % Z; }
int casenum, casei;
int main()
{
	UL M, K;
	while (~scanf("%llu%llu", &M, &K))
	{
		UL ans = K * (M - K + 1);
		printf("%llu\n", ans);
	}
	return 0;
}
/*
【trick&&吐槽】
敢猜敢过。~没加,收获SB的 OLE

【题意】
有M个格子,有K个物品。我们希望在格子与物品之间连数量尽可能少的边,使得——不论是选出M个格子中的哪K个,都可以与K个物品恰好一一匹配。

【分析】
看样例可以猜答案,答案就是(M - K + 1) * K

从这个答案去猜测原因——
每个物品,都要向(M - K + 1)个格子连去一条边,我们会丢弃M - K个格子,但总会剩下一个格子是与这个物品连边的。

但是还要完成一一匹配的关系。
这个要怎么保证呢?如果让我们构造并输出一组方案怎么办?

连边方式就是:
1 -> [1, M - K + 1]
2 -> [2, 1 + M - K + 1]
3 -> [3, 2 + M - K + 1]
K -> [K, M]

这样不论选哪些格子,第一个物品总是能匹配第一个格子,第二个物品总是能匹配第二个格子…… 所以总能合法匹配!

【时间复杂度&&优化】
O(1)

*/



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值