HDU1019 The Least Common Multiple

题目:

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296
//思路:由于两个数的最小公倍数等于两数之积除以两数的最大公倍数,就先求出两个数的最小公倍数,再求这个公倍数和别的数的最小公倍数
#include<stdio.h>
#include<stdlib.h>

int GCD(int,int);
int LCM(int,int);
//养成好习惯 ,声明函数
int GCD(int a,int b)
{
	if(b==0)return a;
	else GCD(b,a%b);
}
//这里要求a严格大于等于b
int LCM(int a,int b)
{
	int c,re,gcd;
	if(a<b)
	{
		c=a;
		a=b;
		b=c;
	}
	gcd=GCD(a,b);
	/*
	这里也可以比较a,b大小,
	然后调用GCD()时候,
	将较小的一个数放在后面,较大的放前面。
	*/
	re=a*(b/gcd);
	/*
	第一次交的时候,wa了,觉得逻辑没有问题,
	百度发现有人说a*b时候可能溢出,就先让b/gcd,减小一点,
	然后就过了
	*/
	return re;
}
//用两个函数可能有些累赘,求最小公倍数的可以直接写在main函数里

int main()
{
	int n,m,i,j,lcm,a;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&m);
		scanf("%d",&lcm);
		for(j=1;j<m;j++)
		{
			scanf("%d",&a);
			lcm=LCM(lcm,a);
		}
		printf("%d\n",lcm);
	}
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值