POJ 1952 LITTLE SHOP OF FLOWERS(DP动归,最长递减子序列)

题目地址:http://poj.org/problem?id=1952

                    

  BUY LOW, BUY LOWER

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8651 Accepted: 2994

    

Description

The advice to "buy low" is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems' advice:
                    "Buy low; buy lower"

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices.

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy.

Here is a list of stock prices:
 Day   1  2  3  4  5  6  7  8  9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87


The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is:
Day    2  5  6 10

Price 69 68 64 62

Input

* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given

* Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers.

Output

Two integers on a single line:
* The length of the longest sequence of decreasing prices
* The number of sequences that have this length (guaranteed to fit in 31 bits)

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they "look the same" when the successive prices are compared. Thus, two different sequence of "buy" days could produce the same string of decreasing prices and be counted as only a single solution.

Sample Input

12
68 69 54 64 68 64 70 67 78 62
98 87

Sample Output

4 2

Source

USACO 2002 February

     此题是简单的DP题,同时也是非常经典的DP题。如题,此题的主要难度(对于我们这些新手)在于统计最长递减
子序列的个数。
#include<stdio.h>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<queue>
#define ll long long;
#define inf 0x3f3f3f3f
#define ins 0xc0
using namespace std;
int dp[5005], cnt[5005], N, maxlen, mlnum;
int dayp[5005];
int main()
{
	while (scanf("%d", &N) != EOF){
		for (int i = 1; i <= N; i++) scanf("%d", &dayp[i]);
		for (int i = 0; i <= N; i++){
			dp[i] = 0;
			cnt[i] = 0;
		}
		dayp[0] = inf;
		cnt[0] = 1;
		dp[0] = 0;
		maxlen = 1;
		mlnum = 0;
		for (int i = 1; i <= N; i++){
			for (int j = 0; j < i; j++){
				if (dayp[i] < dayp[j]) dp[i] = max(dp[i], dp[j] + 1);  //这是状态转移方程
                         else if (dayp[i] == dayp[j]) cnt[j] = 0;  //解决相同子序列问题
			}
			for (int j = 0; j < i; j++){
				if (dp[i] == (dp[j] + 1) && dayp[i] < dayp[j]){
					cnt[i] += cnt[j];    //cnt[i]表示到第i个时包含dayp[i]元素最长不同子序列个数
				}
			}
			maxlen = max(maxlen, dp[i]);
		}
		for (int i = 1; i <= N; i++) {
			if (dp[i] == maxlen) mlnum += cnt[i];
		}
		printf("%d %d\n", maxlen, mlnum);
	}
	return 0;
}
感谢各位大神的阅读~


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值