题目描述
程序要读入一系列正整数数据,输入-1表示输入结束,-1本身不是输入的数据。程序输出读到的数据中的奇数和偶数的个数。
输入格式:
一系列正整数,整数的范围是(0,100000)。
输入样例:
9 3 4 2 5 7 -1
输出样例:
奇数个数为:4 偶数个数为:2
代码:
#include<stdio.h>
#include<stdbool.h>
int main(){
int x, js = 0, os = 0;
do{
scanf("%d", &x);
if((x <= 0 && x != -1) || x >= 100000)
return 0;
if(x % 2 == 0){
os++;
}else{
js++;
}
}while(x != -1);
printf("奇数个数为:%d 偶数个数为:%d\n",js -1,os);
return 0;
}