Z - Bitset

Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1
2
3
Sample Output
1
10

11


翻译过来就是转换二进制


解题思路:利用进制转换的规则就可以解决。


#include<stdio.h>

void train(int n)
{
	int a[1000];
	int i=0,j;
	while(n>=2)
	{
		a[i]=n%2;
		n=n/2;	
		i++;
	}
	i--;
	printf("%d",n);
	for(j=i;j>=0;j--)
		printf("%d",a[j]);
	printf("\n");
}

int main()
{
	int n;
	while((scanf("%d",&n))!=EOF)
	{
		train(n);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值