输出GPLT

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

**anwser**

#include <stdio.h>
#include <ctype.h>

int main() {
    char str[10001];
    int counts[4] = {0};

    scanf("%s", str);

    for (int i = 0; str[i] != '\0'; i++) {
        switch (tolower(str[i])) {
            case 'g': counts[0]++; break;
            case 'p': counts[1]++; break;
            case 'l': counts[2]++; break;
            case 't': counts[3]++; break;
        }
    }

    while (counts[0] > 0 || counts[1] > 0 || counts[2] > 0 || counts[3] > 0) {
        if (counts[0] > 0) {
            printf("G");
            counts[0]--;
        }
        if (counts[1] > 0) {
            printf("P");
            counts[1]--;
        }
        if (counts[2] > 0) {
            printf("L");
            counts[2]--;
        }
        if (counts[3] > 0) {
            printf("T");
            counts[3]--;
        }
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值