SPOJ 18937 Touch of Venom

Description

Sometimes you have to try fighting even though you know that your enemy is very powerful than you. Your hero with initial health H is about to fight against a venomous enemy who has a poisonous value of P. The enemy's poison deals i*P damage at it's ith attacking chance(i>=1). The hero dies when his health becomes <=0. After enemy's attack, if the hero survives, he heals himself with a health of A by using his skills. Then the enemy gets the chance again and the cycle continues till the hero dies. Find the survival time of the hero. You can safely assume that the hero is mortal.

Example Scenario:

Initial Health(H) = 10, Poison (P) = 2, Heal value(A) = 1

At time 1, enemy does 1*2 damage reducing the hero's health to 8

At time 2, hero heals himself by 1 increasing his health to 9

At time 3, enemy does 2*2 damage reducing the hero's health to 5

At time 4, hero heals himself by 1 increasing his health to 6

At time 5, enemy does 3*2 damage and kill the hero.

The hero survived 5 units of time.

Input:

The first line consists of an integer t, the number of test cases. For each test case there is a line with 3 integers H, P and A.

Output:

For each test case, find the survival time of the hero.

Input Constraints:

1<=t<=10^6

1<=H<=10^6

1<=P<=10^6

0<=A<P

Sample Input:

3

3 7 2

81 4 1

87 8 4

Sample Output:

1

13

9

二分题,如果有人把它当做暴力题来做,而且执迷不悟,那么欢迎前来和聪哥组队去跑马拉松了~~~

直接二分英雄死亡的时间,然后计算判断即可~~~

还剩半个小时开的这道题,乍一看感觉很水,直接模拟,然后果断TLE(10^6的数据,怎么看都不会超时啊!后来看到了丧心病狂的测试组数,T<=10^6,Orz)


#include <cstdio>
typedef long long LL;
int H,P,A;
bool judge(int n){
    LL ans = (LL)(n+1)*n/2*P-(LL)(n-1)*A-H;
    if(ans >= 0) return 1;
    return 0;
}

int main(){
    int kase;
    scanf("%d",&kase);
    while(kase--){
        scanf("%d%d%d",&H,&P,&A);
        int l = 1,r = 1000000,ans = l;
        while(l <= r){
            int mid = (l+r)>>1;
            if(judge(mid))  r = mid-1,ans = mid;
            else    l = mid+1;
        }
        printf("%d\n",ans*2-1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值