POJ 1050(最大子矩阵和)

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 47107 Accepted: 24952

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
分析:
一维数组最大子段和的推广,开始的两层for循环枚举子矩阵的 起始行 与 终止行 ,并将从起始行到终止行的元素按列加起来存到a数组里,这样就变成了一维数组求最大和了,即 tmp 数组的最大子段和,也就是求起始列和终止列,调用函数F即可求出来。有了起始行、终止行、起始列、终止列,子矩阵也就确定下来了,总的时间复杂度为O(n3)。
代码:
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iostream>
using namespace std;

typedef long long int ll; 

const int maxn = 105;
int N;
int matrix[maxn][maxn];
int tmp[maxn];

ll F(int* a){
	ll sum = -9999999999;
	ll this_sum = 0;
	for(int i=0; i<N; i++){
		this_sum += a[i];
		if(this_sum>sum)
			sum = this_sum;
		if(this_sum<0)
			this_sum = 0;
	}
	return sum;
}

int main(){
	
	ll sum,Max=0;
	scanf("%d",&N);
	for(int i=0; i<N; i++)
		for(int j=0; j<N; j++)
			scanf("%d",&matrix[i][j]);
	for(int i=0; i<N; i++){     //行 
		memset(tmp,0,sizeof(tmp));
		for(int j=i; j<N; j++){    //行 
			for(int k=0; k<N; k++)
				tmp[k] += matrix[j][k];
			Max = max(Max,F(tmp));
		}
	}
	printf("%I64d\n",Max);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值