Number lengths

N! (N factorial) can be quite irritating and difficult to compute for large values of N. So instead of calculating N!, I want to know how many digits are in it. (Remember that N! = N * (N - 1) * (N - 2) * ... * 2 * 1)

Input:

Each line of the input will have a single integer N on it 0 < N < 1000000 (1 million). Input is terminated by end of file.

Output:

For each value of N, print out how many digits are in N!.

Sample Input:

1
3 
32000 

Sample Output:

1 
1 
130271 
/*第一种:由于乘数太大会超过整数类型的范围,就把乘积定义为双精度类型,每次乘完除以十,算出位数
第二种:用所求位数log转换为logn!=log1+log2+log3......logn*/
#include<stdio.h>
int main()
{int c,i,n;
float sum;
 while (scanf("%d",&c)!=EOF) 
 {
 n=1;sum=1.0;
   {for(i=1;i<=c;i++)
          {sum=sum*i;
           while(sum>=10)
            {sum=sum/10;n++;}
          }
          printf("%d/n",n);
    }
 
 }return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值