1012 The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output “N/A”.

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

题目大意:给定学生的三门功课的成绩(C,M,E),然后对不同科目进行排序,根据输入的学号,查找学生各科中成绩排名最好的课程名称及相应名次。

分析:针对不同的科目,分别排序,记录相应名次。接着查找某一学生排名最好的科目。最后输出。可使用set标准容器来存储,以此来检查输入的学号是否存在。

备注:排序

参考代码:

#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include<set>
#include<map>

using namespace std;

struct student 
{
    string id;
    int score[4], rank[4], best;   //A、C、M、C
}stu[2005];
int flag = -1;
//注意比较函数
bool cmp(student a,student b)
{
    return a.score[flag] > b.score[flag];
}

int main()
{
    int n, m;
    string name, id;
    cin >> n >> m;
    set<string>exist;
    map<string, int>stuMap;
    for (int i = 0; i < n; i++)
    {
        cin >> name;
        exist.insert(name);
        stu[i].id = name;
        cin >> stu[i].score[1] >> stu[i].score[2] >> stu[i].score[3];
        stu[i].score[0] = (stu[i].score[1] + stu[i].score[2] + stu[i].score[3]) / 3 + 0.5;
    }

    //统计每门科目的排名
    for (flag = 0; flag < 4; flag++)
    {
        sort(stu, stu + n, cmp);
        stu[0].rank[flag] = 1;                 //记录排名
        for (int i = 1; i < n; i++)
        {
            if (stu[i].score[flag] == stu[i - 1].score[flag])
                stu[i].rank[flag] = stu[i - 1].rank[flag];
            else stu[i].rank[flag] = i + 1;
        }
    }

    //查找每个人最好的排名
    for (int i = 0; i < n; i++)
    {
        stuMap[stu[i].id] = i;

        stu[i].best = 0;
        int min = stu[i].rank[0];
        for (int j = 1; j <= 3; j++)
        {
            if (stu[i].rank[j] < min)
            {
                min = stu[i].rank[j];
                stu[i].best = j;
            }
        }
    }

    char ch[4] = { 'A','C','M','E' };
    for (int i = 1; i <= m; i++)
    {

        cin >> id;
        if (exist.find(id) == exist.end())
            cout << "N/A" << endl;
        else {
            int temp = stuMap[id];
            int best = stu[temp].best;
            cout << stu[temp].rank[best] << " " << ch[best] << endl;
        }

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值