1093 Count PAT's

The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10
​5
​​ characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
Sample Output:
2
分析:给定只含有P、A、T三种字符的字符串,求组成的PAT的个数。要找个数,只需找到A之前P的个数np,和A之后T的个数nt,然后np*pt就是包含这个A个PAT个数。
先遍历字符串,记录T的总个数nt;然后再遍历字符串,若字符为P,np自增一;若字符为T,则nt自减一;若字符为A,包含此A的PAT的个数为np*nt;
参考代码:

#include<iostream>
#include<string>
#include<vector>
#define N 1000000007
using namespace std;

int main()
{
    string s;
    cin >> s;
    int result = 0, nump = 0, numt = 0;
    for (int i = 0; i < s.size(); i++) {
        if (s[i] == 'T')
            numt++;
    }
    for (int i = 0; i < s.size(); i++) {
        if (s[i] == 'P')nump++;
        else if (s[i] == 'T')numt--;
        else if (s[i] == 'A') result = (result + (nump*numt) % N) % N;
    }
    cout << result;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值