SGU 115. Calendar (基姆拉尔森公式)

9 篇文章 0 订阅

irst year of new millenium is gone away. In commemoration of it write a program that finds the name of the day of the week for any date in 2001.

Input

Input is a line with two positive integer numbers N and M, where N is a day number in month MN and M is not more than 100.

Output

Write current number of the day of the week for given date (Monday – number 1, … , Sunday – number 7) or phrase “Impossible” if such date does not exist.

Sample Input

21 10

Sample Output

7

用基姆拉尔森公式算出某年某月某日是星期几。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;


int CalculateWeekDay(int y, int m,int d)
{
	if(m==1||m==2)
        m+=12,y--;
	int iWeek = (d+2*m+3*(m+1)/5+y+y/4-y/100+y/400)%7;
	return iWeek + 1;
}

int j[13] = {0,31,28,31,30,31,30,31,31,30,31,30,31};

int main(void)
{
    int m,d;
    while(scanf("%d%d",&d,&m)==2)
    {
        if(m > 12 || m < 1)
        {
            printf("Impossible\n");
            continue;
        }
        if(d > j[m] || d < 1)
        {
            printf("Impossible\n");
            continue;
        }
        printf("%d\n",CalculateWeekDay(2001,m,d));
    }

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值