L2-008. 最长对称子串
时间限制
100 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越
对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定"Is PAT&TAP symmetric?",最长对称子串为"s PAT&TAP s",于是你应该输出11。
输入格式:
输入在一行中给出长度不超过1000的非空字符串。
输出格式:
在一行中输出最长对称子串的长度。
输入样例:Is PAT&TAP symmetric?输出样例:
11
思路:分别对每个点向两侧搜索,直到两侧的结果不一样,n^2的复杂度,过了。上午刚做完,下午就考了,美滋滋~
上代码:
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<queue>
#include<algorithm>
#include<set>
#include<cmath>
#include<string>
#include<cstring>
using namespace std;
char s[1010];
int main()
{
gets(s);
int maxx=1;
int cnt;
int len=strlen(s);
for(int i=0;i<len;i++)
{
cnt=1;
int u=1;
int lx=i-u;
int ly=i+u;
while(lx>=0&&ly<len&&s[lx]==s[ly])
{
cnt+=2;
lx--;
ly++;
}
if(cnt>maxx)
maxx=cnt;
}
for(int i=0;i<len;i++)
{
cnt=0;
int u=1;
int lx=i;
int ly=i+u;
while(lx>=0&&ly<len&&s[lx]==s[ly])
{
cnt+=2;
lx--;
ly++;
}
if(cnt>maxx)
maxx=cnt;
}
printf("%d",maxx);
return 0;
}