ACM DP Phalanx

题目:

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC. 
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position. 
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs. 
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix: 
cbx 
cpb 
zcc
InputThere are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.OutputEach test case output one line, the size of the maximum symmetrical sub- matrix. 
Sample Input
3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0
Sample Output
3
3


大意:给你一个字母矩阵,求出里面的最大反对角矩阵

思路:一个大矩阵对应多个小矩阵的,相当于一个问题对应多个前问题。很显然是一个DP问题,那我们就要找到大矩阵跟小矩阵的关系,沿着大矩阵的对角线,可以发现大矩阵是由小矩阵组成的

用dp[i][j]表示左下角坐标为i,j的反对角矩阵,当然,从右上角也可以。写出dp[i][j]与dp[i-1][j+1]的关系。

代码如下:

#include<stdio.h>
#include<algorithm>
using namespace std;
int dp[1111][1111],n;
char a[1111][1111];
int main()
{
    int b,ans;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        ans=1;//不能是0,因为只有一个字母时 在下面的循环中ans的值是不会改变的;
        for(int i=0;i<n;i++)
            scanf("%s",a[i]);
        for(int i=0;i<n;i++)
        {
            for(int j=n-1;j>=0;j--)
            {
                dp[i][j]=1;
                if(i==0||j==n-1)
                    continue;
                b=dp[i-1][j+1];
                for(int m=1;m<=b;m++)
                {
                    if(a[i-m][j]==a[i][j+m])
                        dp[i][j]++;
                    else
                        break;//有不满足的即使后面满足也不是对应大小的对称矩阵了
                }
                ans=max(ans,dp[i][j]);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值