Sightseeing



Sightseeing
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

 

Description


Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.
Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.
There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.
Sightseeing(最短路次短路) - Steppedby - Steppedby
For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.
Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length. 
 
Input


The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.
M lines, each with three integers A, B and L, separated by single spaces, with 1 ≤ A, B ≤ N, A ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L.
The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.
One line with two integers S and F, separated by a single space, with 1 ≤ S, F ≤ N and S ≠ F: the starting city and the final city of the route.
There will be at least one route from S to F. 

 Output

For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 10^9 = 1,000,000,000. 
 

Sample Input


2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1


Sample Output
3
2 


 
分析:题目大意是旅行团从一点(st)到另外一点(en),为了省油同时为了让旅客能看到更多的景点,选择最短路以及比最短路长度多1的次短路。可能存在重边,不能用邻接矩阵建图,用邻接表。其中,最短路和次短路的更新大致有以下四种情况:

1.新路径比最短路短,更新次短路、最短路的长度和数目;

2.新路径与最短路相等,更新最短路的数目;

3.新路径比次短路短,更新次短路的长度和数目;

4.新路径与次短路相等,更新次短路的数目;

代码:

#include"cstdio"
#include"cstring"
#include"iostream"

using namespace std;

#define INF 0x7f7f7f7f

int n,m;
int cnt;
int head[1005]; //以i出发的最后一条边
int dis[1005][2]; //dis[i][0]:到i的最短路长度,dis[i][1]:到i的次短路长度
int num[1005][2]; //num[i][0]:到i的最短路数目,num[i][1]:到i的次短路数目
bool vis[1005][2];

struct Edge //第i条边的信息
{
    int next,to;//next:头结点  to:尾
    int dis;
}edge[10005*2];

void init()
{
    memset(vis,false,sizeof(vis));
    memset(num,0,sizeof(num));
    for(int i = 1;i <= n;i++)
    {
        dis[i][0] = INF;
        dis[i][1] = INF;
    }
}

void AddEdge(int from,int to,int dis) //邻接表建边
{
    edge[cnt].to = to;
    edge[cnt].dis = dis;
    edge[cnt].next = head[from];
    head[from] = cnt ++;
}

void dij(int st,int en)
{
    init();
    dis[st][0]=0;
    num[st][0]=1;
    for(int i = 1;i < 2*n;i++)
    {
        int mark,flag;
        int minn = INF;
        for(int j = 1;j <= n;j++)      //找最短路和次短路(长度最小的边)
        {
            if(!vis[j][0] && dis[j][0] < minn)  //最短路
            {
                minn = dis[j][0];
                flag = 0;
                mark = j;
            }
            else if(!vis[j][1] && dis[j][1] < minn) // 次短路
            {
                minn = dis[j][1];
                flag = 1;
                mark = j;
            }
        }
        if(minn == INF) break;  //未找到最短路或次短路退出循环
        vis[mark][flag] = true;
        for(int j = head[mark];j != -1;j = edge[j].next) //更新与mark相连的边
        {
            int t = edge[j].to;
            if(dis[t][0] > minn + edge[j].dis) //小于最短路,更新最短路、次短路的长度和数目
            {
                dis[t][1] = dis[t][0];
                dis[t][0] = minn + edge[j].dis;
                num[t][1] = num[t][0];
                num[t][0] = num[mark][flag];
            }
            else if(dis[t][0] == minn + edge[j].dis) //等于最短路,更新最短路的数目
            {
                num[t][0] += num[mark][flag];
            }
            else if(dis[t][1] > minn + edge[j].dis) //小于次短路,更新次短路的数目和长度
            {
                dis[t][1] = minn + edge[j].dis;
                num[t][1] = num[mark][flag];
            }
            else if(dis[t][1] == minn + edge[j].dis)   //等于次短路,更新次短路的数目
            {
                num[t][1] += num[mark][flag] ;
            }
        }
    }
    if(dis[en][1] == dis[en][0] + 1)  // 次短路比最短路多1的时候,输出次短路和最短路的和
    {
        num[en][0] += num[en][1];
    }
    printf("%d\n",num[en][0]);
}

int main()
{
    int cas;
    while(~scanf("%d",&cas))
    {
        while(cas--)
        {
            cnt = 0;
            memset(head,-1,sizeof(head));
            scanf("%d%d",&n,&m);
            int a,b,l;
            while(m--)
            {
                scanf("%d%d%d",&a,&b,&l);
                AddEdge(a,b,l);
            }
            int st,en;
            scanf("%d%d",&st,&en);
            dij(st,en);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值