hdu1030



Delta-wave

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5858    Accepted Submission(s): 2219


Problem Description
A triangle field is numbered with successive integers in the way shown on the picture below.



The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length of the traveller's route.

Write the program to determine the length of the shortest route connecting cells with numbers N and M.
 

Input
Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).
 

Output
Output should contain the length of the shortest route.
 

Sample Input
  
  
6 12
 

Sample Output
  
  
3
 

源代码:
#include<iostream>
using namespace std;
int c1,c2,h1,h2,x;
void load(int c,int h,int s)
{
   if(h==h2){
      if(c-c2>0)
    x=s+c-c2;
   else x=s+c2-c;
      return ;
    }
   if(c%2==1)
     load(c+1,h+1,s+1);  
   else if(c2-(h2-h)>c)
    load(c+1,h,s+1);
   else
    load(c-1,h,s+1);
}
void search(int num,int c)
{
  int i,j,k;
  for(k=0,j=i=1;;i++,j+=2){
    k+=j;
    if(num<=k&&c==1){
  h1=i;
  c1=num-(k-j);
  break;
    }
    else if(num<=k&&c==2){
  h2=i;
     c2=num-(k-j);
     break;
 }
  }
}
int main()
{
    int m,n,temp;
    while(1)
    {
  cin>>m>>n;
     if(m>n) {temp=m;m=n;n=temp;}
  search(m,1);
        search(n,2);
        load(c1,h1,0);
        cout<<x<<endl;
   }
   return 0;
}
这道题难点在于衔接点为三角形,不能直接像下棋的程序一样直接用上下左右递归,需要对数字所在行的位置的奇偶进行判别。挺水的一道题
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值