HDU 2814 斐波那契循环节+欧拉函数降幂

Interesting Fibonacci

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1072 Accepted Submission(s): 230

Problem Description
In mathematics, the Fibonacci numbers are a sequence of numbers named after Leonardo of Pisa, known as Fibonacci (a contraction of filius Bonaccio, “son of Bonaccio”). Fibonacci’s 1202 book Liber Abaci introduced the sequence to Western European mathematics, although the sequence had been previously described in Indian mathematics.
The first number of the sequence is 0, the second number is 1, and each subsequent number is equal to the sum of the previous two numbers of the sequence itself, yielding the sequence 0, 1, 1, 2, 3, 5, 8, etc. In mathematical terms, it is defined by the following recurrence relation:
这里写图片描述
That is, after two starting values, each number is the sum of the two preceding numbers. The first Fibonacci numbers (sequence A000045 in OEIS), also denoted as F[n];
F[n] can be calculate exactly by the following two expressions:
这里写图片描述
A Fibonacci spiral created by drawing arcs connecting the opposite corners of squares in the Fibonacci tiling; this one uses squares of sizes 1, 1, 2, 3, 5, 8, 13, 21, and 34;

So you can see how interesting the Fibonacci number is.
Now AekdyCoin denote a function G(n)
这里写图片描述
Now your task is quite easy, just help AekdyCoin to calculate the value of G (n) mod C

Input
The input consists of T test cases. The number of test cases (T is given in the first line of the input. Each test case begins with a line containing A, B, N, C (10<=A, B<2^64, 2<=N<2^64, 1<=C<=300)

Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the value of G(N) mod C

Sample Input
1
17 18446744073709551615 1998 139

Sample Output
Case 1: 120

Author
AekdyCoin

Source
HDU 1st “Old-Vegetable-Birds Cup” Programming Open Contest

题意:
求F(a^b)^(F(a^b)^(n-1))%c
a,b,n是longlong范围内的正整数
c是一个小于300的余数

思路:
不难发现c小于300是有意而为的
这里有两个定理:
1.在模c的状态下,斐波那契具有循环节性质,即F[a^b]=F[a^b%len] len即循环节
2.我们可以通过欧拉函数来进行降幂,即a^b%c=a^(b%φ(c)+φ(c))%c

F(a^b)^(F(a^b)^(n-1))%c

= F(a^b)^(F(a^b)^(n-1)%φ(c)+φ(c))%c

=F(a^b%loop1)^(F(a^b%loop2)^(n-1)%φ(c)+φ(c))%c

–》先将斐波那契循环节找到(loop1表示模c状态下的循环节,loop2表示模φ(c)状态下的循环节)

这样就可以直接用快速幂求了

有一点没明白的就是大多数题解的方案都是特判c=1与φ(c)=1的情况
后来和zw讨论了一下,发现特美特判其实都一样c=1的时候就是0
φ(c)=1的时候c=1或c=2,可以直接输出a

#include <iostream>
#include <string.h>
#include <stdio.h>

using namespace std;
typedef unsigned long long LL;

int c;
LL a, b, n;
LL f[5500];

int search(int c) {
    int loop;
    f[0] = 0;
    f[1] = 1;
    for (int i = 2; i < 2005; i++) {
        f[i] = (f[i - 1] % c + f[i - 2] % c) % c;
        if (f[i] == 1 && f[i - 1] == 0) {
            loop = i;
            break;
        }
    }
    return loop - 1;
}

int phi(int n) {
    int rea = n, i;
    for (i = 2; i * i <= n; i++) {
        if (n % i == 0) {
            rea = rea - rea / i;
            while (n % i == 0)
                n /= i;
        }
    }
    if (n > 1)
        rea = rea - rea / n;
    return rea;
}

LL multi(LL a, LL b, LL m) {
    LL ans = 0;
    while (b) {
        if (b & 1) {
            ans = (ans + a) % m;
            b--;
        }
        b >>= 1;
        a = (a + a) % m;
    }
    return ans;
}

LL quick_mod(LL a, LL b, LL m) {
    LL ans = 1;
    a %= m;
    while (b) {
        if (b & 1) {
            ans = multi(ans, a, m);
            b--;
        }
        b >>= 1;
        a = multi(a, a, m);
    }
    return ans;
}

int main() {
    int t, tt = 1;
    LL tmp1, tmp2;
    LL t1, t2;
    scanf("%d", &t);
    while (t--) {
        scanf("%I64u%I64u%I64u%d", &a, &b, &n, &c);
        printf("Case %d: ", tt++);
        if (c == 1) {
            puts("0");
            continue;
        }
        int p = phi(c);
        int loop1 = search(c);
        t1 = quick_mod(a, b, loop1);
        tmp1 = f[t1] % c;
        int loop2 = search(p);
        t2 = quick_mod(a, b, loop2);
        tmp2 = f[t2] % p;
        tmp2 = quick_mod(tmp2, n - 1, p);
        tmp2 += p;
        tmp1 = quick_mod(tmp1, tmp2, c);
        printf("%I64u\n", tmp1);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值